This project is read-only.

Server talk

Apr 27, 2009 at 9:46 PM
Edited Apr 28, 2009 at 3:57 AM
I have dealt with the Codeplex SVN issue as it was just erroring because the svn folders were incorrectly pointing to the wrong directory. The solution was to do another full checkout for it to rebuild the folders. now it works like a charm.

As far as separating SmartMap from the RPG Game, hey are basically two different projects with different licenses and namespaces. Either way, it's up to nowherestudios.
For now I like them on the same servcr I guess. They are very closely related and one shows the power of the other. SmartMap will eventually have more power on it's own though but I am not sure yet.

Also I like Codeplex for now. The forum is nicely integrated with th issue tracker and stuff. If there are more problems I will set something up on sourceforge but remain on Codeplex too.
Apr 28, 2009 at 11:29 PM
If you want to create new files in your SVN directory on the computer, use the Add button so it creates appropriate SVN folders for it. Don't copy and paste any different svn folder into another svn directrory or it wont work right. You can copy and paste just raw files though and then TortoiseSVN->Add them.
Apr 29, 2009 at 9:04 AM
I didnt thought that you have tried to copy your svn to another. I thought you would know about that... It will surely give errors if you copy _svn folder to another SVN root.

The best approach is first export your files from source SVN to another SVN located destination then TortoiseSVN > Add... to them.

Optionally you could open your hidden system folders to view then only copy files other than  _svn directory to your destination, (It also requires Add action to create their _svn folders)
This is also the same way that, what export operation does. But take care, since every subfolder have _svn folders so you must copy every subdirectories individually..
Apr 29, 2009 at 12:38 PM
Good info, also what problems were you having with svn? Was it similar?
Apr 29, 2009 at 9:26 PM
No i think it was just a svn server down for a few minutes. It never happened again.